+ Reply to Thread
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 165

Thread: Payment issues..

Hybrid View

  1. #1
    Junior Member riz is on a distinguished road
    Join Date
    Aug 2010
    Posts
    10

    Payment issues..

    So yeah, im sitting here wanting to give id money, they dont seem to want it. When I try to make a payment I get "We could not process your order. Please verify your information and try again." message over and over.

    Iv tried three diff cards, Maestro/Solo/Visa... none have worked, each one has came up with the same message. My info is 100% accurate, the cards have more than enough money on.

    I know what the verification code is when using the visa(last 3 digits on the back), the maestro/solo cards dont have an issue number.

    No one I know has a credit card, if they did im sure they wouldnt lent me it to put their details up on some website.

    What can I do?

  2. #2
    Member Leadcore is on a distinguished road
    Join Date
    Aug 2010
    Location
    MEEEECHIGAN
    Posts
    54
    wish i knew....i can't give them money either..same as you.

  3. #3
    *cheesyFries
    Guest
    turn off noscript. I got that when it was blocking the server.

  4. #4
    Junior Member YaZoR is on a distinguished road
    Join Date
    Aug 2010
    Posts
    8
    Tried 5 different cards about 40-ish times. Never worked and always get said issue.
    Last edited by Lam; 08-09-2010 at 07:27 AM.

  5. #5
    Member perpetual_war is on a distinguished road
    Join Date
    Aug 2010
    Posts
    47
    Quote Originally Posted by cheesyFries View Post
    turn off noscript. I got that when it was blocking the server.
    what noscript ?

  6. #6
    Member Leadcore is on a distinguished road
    Join Date
    Aug 2010
    Location
    MEEEECHIGAN
    Posts
    54
    I don't have noscript installed....its gotta be an issue with their payment vendor. Hopefully they are pci compliant!

  7. #7
    Junior Member riz is on a distinguished road
    Join Date
    Aug 2010
    Posts
    10
    maybe its worth adding im with Natwest and all the cards iv used are with them..

    I know a few lucky people have been able to pay by debit card from the uk, so god knows..

  8. #8
    *cheesyFries
    Guest
    Quote Originally Posted by Leadcore View Post
    I don't have noscript installed....its gotta be an issue with their payment vendor. Hopefully they are pci compliant!
    out of ideas then. I had exact same message for about 30 min last night until I realised my browser was blocking connections to one place. Once I allowed it the payment went through fine.

  9. #9
    Member perpetual_war is on a distinguished road
    Join Date
    Aug 2010
    Posts
    47
    got same problem..... cant subscribe atm at all :/

  10. #10
    Junior Member YaZoR is on a distinguished road
    Join Date
    Aug 2010
    Posts
    8
    I've tried 5 cards from 3 different UK banks.

    Visa
    Visa Debit
    Mastercard
    Maestro

    =(

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts