+ Reply to Thread
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 30

Thread: Ping and Hitbox / RG/LG

  1. #1
    Senior Member Infinitiy is on a distinguished road
    Join Date
    Aug 2010
    Posts
    102

    Question Ping and Hitbox / RG/LG

    Hello everybody

    We know that sometimes we see that we hit somebody but the hitbox was not at that position where the model was. So I want to know:

    Example i know that my Ping is 20? 30? in average! okay we say 30.
    I see a model and it walks or strafejumps to the left on my screen.

    Where is the Hitbox?

    is there a difference between run with 320speed and strafjumping with 600speed?

    Is there a possibility to estimate the Hitbox?

    The same with LG

    Thanks

  2. #2
    Senior Member Cat will become famous soon enough Cat will become famous soon enough Cat's Avatar
    Join Date
    Aug 2010
    Location
    Sweden
    Posts
    1,905
    The general consensus is that the hitbox lags a little behind the model.

  3. #3
    Senior Member Infinitiy is on a distinguished road
    Join Date
    Aug 2010
    Posts
    102
    Okay and why is the hitbox behind the model? Why it cant be at the same position. Why needs the hitbox more time to send than the model?

  4. #4
    Senior Member Cat will become famous soon enough Cat will become famous soon enough Cat's Avatar
    Join Date
    Aug 2010
    Location
    Sweden
    Posts
    1,905
    Quote Originally Posted by Infinitiy View Post
    Okay and why is the hitbox behind the model? Why it cant be at the same position. Why needs the hitbox more time to send than the model?
    It's a problem with the anti-lag code. SyncError has said they're aware of it and are working on improving it.

  5. #5
    Senior Member Lorfa is a jewel in the rough Lorfa is a jewel in the rough Lorfa is a jewel in the rough Lorfa's Avatar
    Join Date
    Aug 2010
    Location
    Kepler-22b
    Posts
    8,487
    Quote Originally Posted by Cat View Post
    The general consensus is that the hitbox lags a little behind the model.
    Quote Originally Posted by Infinitiy View Post
    Okay and why is the hitbox behind the model? Why it cant be at the same position. Why needs the hitbox more time to send than the model?
    I was under the impression that the hitbox does not lag behind the model, but that the model/hitbox are not where they appear to be under lagged conditions.

    As in a client sends a move request, the server gets it and moves the client the sent amount and then sends the new data to be received by all clients in the next update. The other clients receive the information but with a delay.

    So by the time your presumably lagged client sees the player change positions they have actually moved from that position. The phenomenon is amplified the greater the latency.

    I'm not sure how it actually works, just an idea. I know the 'unlagged' code helps with some of this, but cannot be used too much because it introduces its own side effects.

  6. #6
    Senior Member NEPHIREM is on a distinguished road NEPHIREM's Avatar
    Join Date
    Aug 2010
    Location
    Varazdin, Croatia
    Posts
    314
    Sry for slight off-topic but this is what happened to me the other day:

    http://img826.imageshack.us/img826/6597/aaaacy.th.jpg

    Crosshair is on the enemy but but rail beam itself seems to be slightly off - the shot misses (instagib). Dude was standing still and ping was around 50. How is that possible, I thought that crosshair should be more accurate than the beam?

  7. #7
    Senior Member Infinitiy is on a distinguished road
    Join Date
    Aug 2010
    Posts
    102
    yeah thats a real **** up...

  8. #8
    Senior Member Lorfa is a jewel in the rough Lorfa is a jewel in the rough Lorfa is a jewel in the rough Lorfa's Avatar
    Join Date
    Aug 2010
    Location
    Kepler-22b
    Posts
    8,487
    Quote Originally Posted by NEPHIREM View Post
    Sry for slight off-topic but this is what happened to me the other day:

    http://img826.imageshack.us/img826/6597/aaaacy.th.jpg

    Crosshair is on the enemy but but rail beam itself seems to be slightly off - the shot misses (instagib). Dude was standing still and ping was around 50. How is that possible, I thought that crosshair should be more accurate than the beam?
    Would prefer a demo, but ya crosshair more accurate than the beam.

    Maybe you just found the perfect angle that misses the hit cylinder.

  9. #9
    Senior Member NEPHIREM is on a distinguished road NEPHIREM's Avatar
    Join Date
    Aug 2010
    Location
    Varazdin, Croatia
    Posts
    314
    Ok, here's the demo.

    http://www.mediafire.com/?11kbjmc361xj124

    That shot is at 1:02 (as you can see on the screenshot).
    Please dont comment my (lack of) skill as i know i suck. ^^

  10. #10
    Senior Member Cat will become famous soon enough Cat will become famous soon enough Cat's Avatar
    Join Date
    Aug 2010
    Location
    Sweden
    Posts
    1,905
    Quote Originally Posted by NEPHIREM View Post
    Ok, here's the demo.

    http://www.mediafire.com/?11kbjmc361xj124

    That shot is at 1:02 (as you can see on the screenshot).
    Please dont comment my (lack of) skill as i know i suck. ^^
    Too lazy to watch. Did he get hit by any later shots? Might've been the no-hitbox bug.

    And the hitboxes do lag behind. I hit enough rails to be pretty sure on that point.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts