+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14

Thread: Removing shadows on the environment

  1. #1
    *trikzzz
    Guest

    Removing shadows on the environment

    Hi,

    I saw a screenshot today where the environment had no shadows, like so:

    http://img826.imageshack.us/img826/639/shot0004j.jpg

    But mine looks like this:

    http://img52.imageshack.us/img52/548/shot0000te.jpg

    Those shadows are quite ugly, anyone know which command removes them? Thanks.

  2. #2
    Banned DCR is on a distinguished road
    Join Date
    Aug 2010
    Posts
    685
    There are several ways to achieve this.
    Basically r_fullbright 1 with r_mapoverbrightbits 0 , r_overbrightbits 0, then tweakup r_intensity from its default 1 should get u somewhat closer. In addition to that you'll need r_vertexlight 1 and a suitable r_picmip starting from 6 and higher (max 16).
    I prefer r_vertexlight 0 tho, since u get the smoothest transparent lg/explosions with it, albeit at a slight fps cost sometimes.
    You can also play with r_lightmap 1 with r_vertexlight 0.

  3. #3
    *trikzzz
    Guest
    I tried those commands and managed something very similar.

    However, now that I've seen it in-game I don't like it, much prefer what I had before. :p

    Thanks for the help though.

  4. #4
    *hypersapiens
    Guest
    cg_shadows 0
    r_drawsun 0
    and maybe r_dynamiclight 0

    Should only remove shadows and leave the rest as it is.

  5. #5
    Senior Member joz is on a distinguished road
    Join Date
    Aug 2010
    Location
    England
    Posts
    346
    Fullbright lighting looks like crap and isnt in the screenshot he posted. That is vertex lighting (and before the lighting update i think, so you cant get it exactly like that).

    The only configuration i have found that actually works with vertex lighting is this: (any other values of overbright/mapoverbrightbits make some maps much too bright or some much too dark)

    r_mapoverbrightbits 1
    r_overbrightbits 1
    r_vertexlight 1
    r_lightmap 0
    r_fullbright 0
    r_picmip 16

  6. #6
    Senior Member Salamatiqus is on a distinguished road Salamatiqus's Avatar
    Join Date
    Aug 2010
    Location
    Astana, Kazakhstan
    Posts
    1,538
    Sorry, offtopic: Hey, trikzzz, can you share your HUD? :>
    bind END "quit'

  7. #7
    *trikzzz
    Guest
    Quote Originally Posted by hypersapiens View Post
    cg_shadows 0
    r_drawsun 0
    and maybe r_dynamiclight 0

    Should only remove shadows and leave the rest as it is.
    Those are the settings I already use.

    Quote Originally Posted by J0Z View Post
    Fullbright lighting looks like crap and isnt in the screenshot he posted. That is vertex lighting (and before the lighting update i think, so you cant get it exactly like that).

    The only configuration i have found that actually works with vertex lighting is this: (any other values of overbright/mapoverbrightbits make some maps much too bright or some much too dark)

    r_mapoverbrightbits 1
    r_overbrightbits 1
    r_vertexlight 1
    r_lightmap 0
    r_fullbright 0
    r_picmip 16
    You're right those settings look almost exactly like it. I've decided I don't like vertexlight though. Prefer what I had before

    I'd be interested if I could get rid of the shadows and keep everything else the same but that doesn't seem possible unfortunately.

    Appreciate the help.

    Quote Originally Posted by Salamatiqus View Post
    Sorry, offtopic: Hey, trikzzz, can you share your HUD? :>
    Sure, I didn't make it. Pretty sure it's this one: http://qlhud.core.ws/id/Qvxd45
    Last edited by trikzzz; 09-22-2010 at 05:50 AM.

  8. #8
    Banned DCR is on a distinguished road
    Join Date
    Aug 2010
    Posts
    685
    Quote Originally Posted by trikzzz View Post
    I'd be interested if I could get rid of the shadows and keep everything else the same but that doesn't seem possible unfortunately.
    If u mean that u want like the default config to simply be without shadows, then all u have to do is to enable r_fullbright 1.
    That's r_fullbright 1 with r_vertexlight 0.

  9. #9
    *trikzzz
    Guest
    Quote Originally Posted by DCR View Post
    If u mean that u want like the default config to simply be without shadows, then all u have to do is to enable r_fullbright 1.
    That's r_fullbright 1 with r_vertexlight 0.
    I meant my config without shadows. :p

  10. #10
    Banned DCR is on a distinguished road
    Join Date
    Aug 2010
    Posts
    685
    i dont know ur config but i dont have any shadows with r_fullbright 1. What exactly is it that u want?

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts