Hey there !

I've been having some issues the last few days : Quakelive plug-in won't load on both Chrome and Firefox latest versions. First it always tells me that I need to download QuakeLivePlugin_520, and if I click on the link saying "Click here if quakelive doesn't load", I arrive on the main screen browsing the games, but I can't join any game as it says I'm downloading required data. This is the first time it happens, I've not changed anything with my conf.

I'm a mac user using 10.6.8 version of Os X.

Can anyone help ?

Thanks