+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 11 to 14 of 14

Thread: Starting quake live plugin...

  1. #11
    Senior Member Lam has a spectacular aura about Lam has a spectacular aura about Lam has a spectacular aura about Lam's Avatar
    Join Date
    Aug 2010
    Posts
    3,763
    - Crash signature matches 3 reported crashes in Mozilla database in the last month. All are from Ubuntu, all from Firefox 22, all from nvidia 319.32 on a GT 440. Probably your reports? :) If not - you can downgrade/upgrade FF and drivers to see if it's this combo of versions crashing it.

    (We know it was working for you on older versions, but also there are newer versions available to test.)

    - If you're afraid of 64-bit compatibility, just try a 32-bit Firefox.

    - I was making "XPI hacks" back in the day, but that wasn't touching any code, only changed supported Firefox versions in file manifest, nothing more. This is no longer needed, but even when it was, nothing was crashing. Simply - browser refused to install the extension. As you see, this can't be connected to your problem in any way.

    - It's unlikely but of course still possible that QL update broke something just for you, or that you have somehow broken QL in the meantime. I suggest removing your configs from ~/.quakelive/quakelive/home/baseq3/*.cfg and resetting everything through the website (Settings -> Game Settings -> Reset Settings Defaults). This way you'll make sure it's not your config/HUD/whatever messing up QL.

  2. #12
    Junior Member ChickenBoo is on a distinguished road
    Join Date
    Aug 2010
    Posts
    7
    If the Crash signature is associated with lots of porn dloads, then it's my evil twins computer! lol
    Mine is sleak and clean behind the ears.

    Like I've said before, I've tried all the combination, from old version and new version for FF with drivers.
    I may try old versions of nvidia drivers and see what happens.

    I will look into 32 bit FF (I also read some1 was successful with qlprism)

    the XPI hacks I was talking about was different. Had to do with plugin-container. It was a tempory patch.

    Again, I have tried fresh installs of quakelive to old/new and FF/linux with no added HUD or custom config. Same plugin crash result.

    This started with the update on 7-16 when the advertisement for Q-con file was added. My game wouldn't load unless I deleted the ad file (a solution someone suggested in the forum) Then it would be writen in everytime i log in. Sort of like a trojan.

    Then after the 7-18 update my first game crashed in the middle of playing. Then it continue to crash everytime i tried to join a game. Now it crashes everytime i log in and once after i join a game. It's random so I can't pinpoint what cause the crash. Resetting thru website doesn't help either.


    My only lead right now are:

    1) the new updates are the cause of the problems...
    2) Nvidia drivers
    3) Ip ban (I certainly haven't done anything to deserve being ban, unless i somehow pissoff a moderator?)

    What was done differently in the recent updates which resulted the same crash through 4 different linux/FF combination?

    I don't think my situation is unique, as I've seen numerous post of people's having the same plugins crash.

    I was hoping we could find the answer that might help me and the hundred of people currently posting with the same problem.

    Is there any clues to whomever's 3 crash signature reports in Mozilla?

  3. #13
    Junior Member ChickenBoo is on a distinguished road
    Join Date
    Aug 2010
    Posts
    7
    *Side Note: on login crash i dont get the countdown and ql wont load beyond the ad red screen even with the script and adblock

  4. #14
    Senior Member Lam has a spectacular aura about Lam has a spectacular aura about Lam has a spectacular aura about Lam's Avatar
    Join Date
    Aug 2010
    Posts
    3,763
    Quote Originally Posted by ChickenBoo View Post
    the XPI hacks I was talking about was different. Had to do with plugin-container. It was a tempory patch.
    If you mean disabling OOPP, you can still try it by opening about:config and toggling dom.ipc.plugins.enabled. This has nothing to do with the xpi, though. And if you disable it, whole browser will start crashing, instead of just a plugin. So remember to put it back on true after you're done with your test.

    Quote Originally Posted by ChickenBoo View Post
    This started with the update on 7-16 when the advertisement for Q-con file was added. My game wouldn't load unless I deleted the ad file (a solution someone suggested in the forum) Then it would be writen in everytime i log in. Sort of like a trojan.
    That wasn't crashing anything, just servers thought players have unpure binaries and prevented us from playing. That was a global QL problem that affected everyone who reloaded the page in that time. Also, it was fixed shortly. Nothing to do with your current problem.

    Quote Originally Posted by ChickenBoo View Post
    I don't think my situation is unique, as I've seen numerous post of people's having the same plugins crash.

    I was hoping we could find the answer that might help me and the hundred of people currently posting with the same problem.
    Can you link some of those hundred posts? I'm trying to keep up with this forum (and also ESR and Nvidia Linux forum) and lots of people have problems (including crashes) but nothing matches yours.

    Quote Originally Posted by ChickenBoo View Post
    I will look into 32 bit FF (I also read some1 was successful with qlprism)
    Do it finally :)


    One last thing I remembered!

    There is another known crash in the Linux QL plugin that probably isn't related to your problem, but the interesting thing is that that one is bound to the account you log into. (If you're interested, plugin starts crashing on login if your account has anyone on /blocklist. So never ever use /block on Linux!)

    So just to confirm if your problem isn't similar in a way, you can create another QL account and try playing on it.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts