+ Reply to Thread
Results 1 to 3 of 3

Thread: 55 ping feels like 200 ping

  1. #1
    Member D_Instinct is on a distinguished road
    Join Date
    Aug 2010
    Posts
    62

    55 ping feels like 200 ping

    I have a 40 Mbit dedicated connection, a 5ghz CPU, a 2gb video card with 16gb/2000 of ram and a SA950 120Hz monitor and it's all tweaked to run as fast as possible. I have no problem with any other online games like BF3 yet when I play Quake live I am constantly getting railed after I move behind cover as if I'm getting hit where I was a second or 2 ago and 90% of my rails go through my opponents. Also my lg may be locked right on the target yet does not cause any damage, rockets seem to move very slow and when they hit they cause very little damage or movement to my opponent, even weapon switching is extremely slow for some reason. Everything feels very sluggish, slow to respond and out of sync.

    I notice that this always happens when my ping may be listed as 55 during the game but at the end of the game will show around 120 yet it feels like a 200 ping when playing. Whenever my pings holds a 55 to 60 ping at the end of the game everything is very responsive and my lg and rail accuracy jump to 50%. The game runs amazing and is very responsive when this occurs, unfortunately it only happens maybe 10% of the time when I do play QL.

    I have even switched internet providers changed routing, tried different qos configs, turned off read ahead frames and have optimized my ql config to the extreme.

    Does anyone have any suggestions as to what could be causing this lag.

  2. #2
    Senior Member Lorfa is a jewel in the rough Lorfa is a jewel in the rough Lorfa is a jewel in the rough Lorfa's Avatar
    Join Date
    Aug 2010
    Location
    Kepler-22b
    Posts
    8,842
    How is your cg_lagometer 2 ?

    Are you using maxpackets 125?

    You could also look into DPC latency, see this thread for ideas: http://www.quakelive.com/forum/showt...GFX-Help/page4

  3. #3
    Senior Member c3 is on a distinguished road
    Join Date
    May 2012
    Posts
    276
    Quote Originally Posted by D_Instinct View Post
    I have a 40 Mbit dedicated connection, a 5ghz CPU, a 2gb video card with 16gb/2000 of ram and a SA950 120Hz monitor and it's all tweaked to run as fast as possible. I have no problem with any other online games like BF3 yet when I play Quake live I am constantly getting railed after I move behind cover as if I'm getting hit where I was a second or 2 ago and 90% of my rails go through my opponents. Also my lg may be locked right on the target yet does not cause any damage, rockets seem to move very slow and when they hit they cause very little damage or movement to my opponent, even weapon switching is extremely slow for some reason. Everything feels very sluggish, slow to respond and out of sync.

    I notice that this always happens when my ping may be listed as 55 during the game but at the end of the game will show around 120 yet it feels like a 200 ping when playing. Whenever my pings holds a 55 to 60 ping at the end of the game everything is very responsive and my lg and rail accuracy jump to 50%. The game runs amazing and is very responsive when this occurs, unfortunately it only happens maybe 10% of the time when I do play QL.

    I have even switched internet providers changed routing, tried different qos configs, turned off read ahead frames and have optimized my ql config to the extreme.

    Does anyone have any suggestions as to what could be causing this lag.
    Hello D-Instinct,

    This sounds like a clear case of 'Input Lag.' I'm assuming you're using an LCD monitor where input lag is prevalent... I dealt w/ this exact same issue for nearly 12 months before I finally resolved it back in May, 2013. This is most likely not an 'Internet/Network' issue, so I wouldn't spend too much time diagnosing your network settings, isps, etc. Although, I do recommend you run 'TCP Optimizer,' to tweak your NIC settings. This does improve your connection for gaming.

    For your input lag issues, first thing you want to do is what Lorfa suggested. Download 'DPC Latency,' run it for 5 minutes, take a screenshot and post back your results. If your DPC is well over 100us, then you have some driver/settings issues. DPC latency over 100us isn't bad, mind you, but for gaming you want it as low as possible. Mine is idle around 2-10us. Under load, it stays well under 100us. I managed to do this through much tweaking and research.

    2nd thing you should do, go into your BIOS and disable 'HPET and all your C-State power settings.' You'll likely see something like c3/c6, etc. Disable all those power saving settings. They basically throttle and down clock your CPU which lowers your system's responsiveness and increases input lag significantly. You'll see a huge bump in responsiveness by disabling HPET and your c-state power settings. Please know how to restore your BIOS settings if you mess something up before starting.

    In windows, make sure that the 'Windows Event Log' service is disabled.

    Also, what kind of video card do you use? Which specific drivers do you use? if running ATI/AMD, I recommend using 12.10 catalyst, and if running nvidia, I recommend driver 295.75. These drivers are stable and known to have very minimal input lag. Check your video card settings, make sure that all scaling is disabled. Display/gpu scaling significantly increases input lag as well. This means you'll have to run @ native resolution of your monitor, which is typically 1920x1080p these days. if you want to use scaling, then you're choosing to increase your input lag. If you're running on a CRT, this is a non-issue.

    Changing your flip/queue, pre-rendered frames also helped out a lot of people... but personally, I feel that your flip queue(AMD/ATI)/pre-rendered frames (Nvidia) should be set to 3. I've tested quite a bit using pre-rendered frames of 3, 2, 1, or 0. I've concluded for myself that 3 is best for Quake Live. 3 is the default setting regardless, but if you wish to mess around with it, you can do so in the Nvidia control panel (if using nvidia). If you have an ati/amd card, you need to download 'Radeon Pro,' to change your flip-queue settings. Note: Flip queue is the same as pre-rendered frames. The two companies use different terms, but both are identical in meaning. A pre-rendered frame is how many frames ahead your GPU prepares before you view it on the screen. Anything above 3 will increase input lag because the GPU is rendering more frames. If you set it to below 3, you deal w/ mouse lag on some settings such as 2. If set to 1 or 0, you may deal w/ stutter and a higher CPU load which directly affects responsiveness. There are many trains of thought on this, FYI. I recommend you stick w/ the default of 3.

    I strongly recommend you go through the below tweak guide. This is the best performance tweak gaming guide on the net, IMO. I also suggest you uninstall your video drivers, and reinstall using the recommended uninstall/reinstall method suggested in the guide. This made a HUGE difference for me.

    http://forums.steampowered.com/forum....php?t=1315790

    The above guide is virtually all you need to resolve your issue. If you have the time, tweak your system. You should see a vast improvement in responsiveness. If you have any questions, I'll try and help you out.

    Good luck.
    Last edited by c3; 07-23-2013 at 03:45 PM.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts