+ Reply to Thread
Results 1 to 6 of 6

Thread: Lag spike every 3-5 mins / Ubuntu 12.10

  1. #1
    *DeviantP
    Guest

    Lag spike every 3-5 mins / Ubuntu 12.10

    Hey guys, I have QL up and running almost perfectly, apart from a rather annoying problem where my ping spikes >999 for about 6-10 seconds every 3-5 mins. My network hardware is running perfectly, and have done a small network stress test which shows no drop in performance in any other applications!

    I've played with the rate settings (from 10,000 to 25,000) but to no avail!

    Does anyone have any suggestions for any other network cmds in QL? or any experience with this issue before?

    Cheers in advance,
    DeviantP

  2. #2
    Senior Member Lorfa is a jewel in the rough Lorfa is a jewel in the rough Lorfa is a jewel in the rough Lorfa's Avatar
    Join Date
    Aug 2010
    Location
    Kepler-22b
    Posts
    8,387
    I think I would first make sure that it is not a background process causing trouble. If everything looks ok I would run a bunch of tracerts, if the spike happens in the earliest hops it indicates that something on your end is causing the problem, either computer, router, modem, or between you and the ISP. This would be good because it means a fix is likely possible, either by troubleshooting your own equipment or having your ISP fix whatever is going on between your residence and them.

    In the middle/end and it's your ISP or just plain routing causing the problem. This is much more difficult to fix as you cannot fix this directly. One way is to use a VPN such as wtfast to change your routing to something that behaves better. Unfortunately this option is not free.

    Most of the QL network cvars won't have an effect on this type of thing. When you're locked up you might try net_restart in console, as it sometimes can shake you out of the lag. Otherwise just use cl_maxpackets 125, rate 25000, as these are the recommended settings and don't cause trouble 99.9999% of the time.

    Even with these settings I used a monitor to see what sort of traffic QL was using, and it came to something like 8k/sec downstream and 2k/sec upstream. I might have those reversed, but still these are pretty small amounts.

  3. #3
    Senior Member pikaluva13 will become famous soon enough pikaluva13's Avatar
    Join Date
    Aug 2010
    Location
    East Lansing, MI
    Posts
    6,206
    Are you using wifi? At home I have the same issue with my connection. I found the best solution for limiting the router issues was to remove as many other devices from accessing the router while playing (Like my phone).

  4. #4
    Junior Member Gentoo is on a distinguished road
    Join Date
    Dec 2012
    Posts
    2
    If you're not using any other network bandwidth it's probably someone else on your network (if there is) things like YouTube can cause ping spikes in games, yet your speed would seem normal on something like SpeedTest or downloading a file. Games are a lot more sensitive than other things when it comes to network performance. If it's none of those sounds like your ISP is just being random.

  5. #5
    Senior Member Lam has a spectacular aura about Lam has a spectacular aura about Lam has a spectacular aura about Lam's Avatar
    Join Date
    Aug 2010
    Posts
    3,763
    This looks like wireless connection and NetworkManager re-scanning networks every few minutes. A QL friend had exactly this problem on his Ubuntu just few weeks ago.

    Probably this can be configured in NetworkManager, but he switched to WICD and that was enough apparently.

    Please, let us know how if this is the problem and how you've dealt with it.

  6. #6
    Member shotoot is on a distinguished road
    Join Date
    Aug 2010
    Posts
    31
    Quote Originally Posted by Lam View Post
    This looks like wireless connection and NetworkManager re-scanning networks every few minutes. A QL friend had exactly this problem on his Ubuntu just few weeks ago.

    Probably this can be configured in NetworkManager, but he switched to WICD and that was enough apparently.

    Please, let us know how if this is the problem and how you've dealt with it.
    omg u save my bottom finally!!!! i am always hated by the community for these lags, great job man, i didn't know lags are for these reasons!

    THANKS!!! I MUST OFFER U A BEER!
    Last edited by Sasparillo; 07-26-2013 at 12:32 PM.

+ Reply to Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts