+ Reply to Thread
Results 1 to 7 of 7

Thread: Linux Q3 live speedup after running game in Wine

  1. #1
    Junior Member BlackBishop is on a distinguished road
    Join Date
    Aug 2010
    Posts
    7

    Linux Q3 live speedup after running game in Wine

    Description of my "discovery"

    If I run Q3 live normally everything runs ok. I have 125 FPS but game does not seem very fluid (I explained this to myself this way after my ping worsened for some reason on all servers about twice few months back). No system change, no major drivers change.

    I installed CrossOver (it was free yesterday ) and checked if it changed performance in Win games run under Wine. Didn't see major change.

    But to my surprise if I run Q3 again after Wine game end Q3 runs sooo much more fluid - so fluid I have never seen before (even under Win). How is that?

    I can't say if it was actually caused by crossover or it was always like this. Does Wine change something in kernel settings (it is not permanent change, it disappears after reboot).

    Can anybody confirm this and explain how does it work?

  2. #2
    Senior Member xwind is on a distinguished road
    Join Date
    Aug 2010
    Posts
    152
    My very old experience from 2004 (or was it 2005? whatever) tells me that on my old PC could handle Q3 on WinXP at circa 85 fps, Suse 9 Linux + wine circa 100 fps, and Suse linux native circa 120 fps. But on all configurations it felt comfortable to play e.g. no ping differences, no mouse lags. So if you asking about performance - yes it's possible, if about some ping issues, well i'd say this is placebo.

  3. #3
    Junior Member BlackBishop is on a distinguished road
    Join Date
    Aug 2010
    Posts
    7
    It is not just about linux being faster than win. In both cases Q3 runs on linux in NATIVE mode - not under wine.

    This is my current cfg:
    Q6600 / 8GB RAM / GTX 260 (302.17 drivers) running Kubuntu 10.04 bit.

    After boot up Q3 displays it is running 125 FPS (rendered not displayed on LCD). But it looks it does not display every frame or not in evenly distributed in time.
    Not I run game under wine (just enter menu and exit) and after that it is very fluid - no it is not placebo as effect is very profound.
    To be exact I entered same Q3 game server so no change in ping, other players stayed on same ping too.
    Sorry but I do not have camera to record it.

    It means something is changed in system - my question is how to track it down.

  4. #4
    Senior Member Lam has a spectacular aura about Lam has a spectacular aura about Lam has a spectacular aura about Lam's Avatar
    Join Date
    Aug 2010
    Posts
    3,761
    What you describe looks like indirect rendering.

    It's typical for the new breed of window managers (with all those funky 3D desktop effects) to make all windows render into buffers, and then decorate / run effects on that. The game itself can then render at 125 frames per second, but into a buffer. The buffer can then be refreshed on your screen at let's say 60 fps (very noticeable) and with vsync on (even though the game doesn't use vsync itself).

    From playing around with Compiz I remember its default value was to force even full screen windows render indirectly and I had to dig in gconf to get rid of that. Early versions of GNOME 3 did the same thing and I couldn't even turn that off. That was years ago, but I still can't shake off the trauma (and use normal old school 2D desktop). You're on Kubuntu, surely with Plasma Dekstop and all the effects, so it rang a bell for me.

    It's also possible that Crossover detects that and is able to tell the decorating window manager to allow direct full screen rendering, or disable vsync, or switch to more frequent updates, or whatever!

    What do you think? Does that sound similar to your symptoms?

    If you can't figure out how to change your WM's behavior (you need to disable compositing somehow - I can't help, not a KDE user), see if you can install some lightweight desktop like XFCE and see if that's good - that'd at least confirm if that's the problem you're seeing.

  5. #5
    Junior Member Pasqoo is on a distinguished road
    Join Date
    Mar 2011
    Posts
    1
    Hi guys, I wanted to play Quake Live from Linux Mint but I noticed I do half fps compared to Windows. It is probably due to open source graphic (AMD) drivers...
    Do you all have proprietary drivers installed?

    These are my informations:
    Code:
    $  glxinfo | grep -i opengl
    OpenGL vendor string: X.Org
    OpenGL renderer string: Gallium 0.4 on AMD CEDAR
    OpenGL version string: 2.1 Mesa 8.0.4
    OpenGL shading language version string: 1.20
    Composite is off, I got Mate 64 bit version.
    Last edited by Pasqoo; 11-11-2012 at 01:48 PM.

  6. #6
    Member applev is on a distinguished road applev's Avatar
    Join Date
    Aug 2010
    Location
    Latvia
    Posts
    70
    Quote Originally Posted by Lam View Post
    see if you can install some lightweight desktop like XFCE and see if that's good - that'd at least confirm if that's the problem you're seeing.
    I can say that I don't see any delay when I run Q3 in fullscreen on Xfce/xfwm4 even with compositing turned on. But thanks for the hint, I'll try to disable it next time I play and see if anything changes.

  7. #7
    Senior Member Lam has a spectacular aura about Lam has a spectacular aura about Lam has a spectacular aura about Lam's Avatar
    Join Date
    Aug 2010
    Posts
    3,761
    Quote Originally Posted by Pasqoo View Post
    Do you all have proprietary drivers installed?
    Yes, and you should, too :)

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts