+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 11 to 12 of 12

Thread: Disable lightning of lg

  1. #11
    Senior Member maltyplaya is on a distinguished road
    Join Date
    Aug 2010
    Posts
    265
    It shouldn't be lagging when you switch weapons. If you have premium, try using the weapon config menu that was added a relatively recently. It would be nice if we could remove the LG beam, I also want to be able to change the colour. Red lightning would just look so cool.

  2. #12
    *Pier4R
    Guest
    Quote Originally Posted by iSuckz View Post
    is there a console command to have gunZ only affect LG ? i tried the weapon options but they are horrid; they induce lag as the cfg is re-written every time you switch weapons (srsly ppl?), they affect all weapons even though they should be weapon-specific (zoomFOV, gunZ etc .. are buggy). they suck.
    Yes, you should use aliases (even if i use cg_gunZ on all weapons), and no the cfg is not rewritten entirely but you change only the value of some commands (as you type them in console).
    Moreover it can be a lot of work is you change a cvar frequently (let's say, each 0.5sec) but i'm not sure but eems that quake deny fast changes. For example i know thta my brain manage continous sounds very bad, so i want to disable hitbeens on lg, then i use:

    Code:
    //alias for sens change
    alias +attackLg "+attack; sensitivity 7.6; cl_mouseaccel 0.005; cg_hitBeep 0;"
    alias -attackLg "-attack; otherWeapSettings"
    alias lgSettings "bind MOUSE1 +attackLg"
    alias otherWeapSettings "bind MOUSE1 +attack; sensitivity 7.6; cl_mouseaccel 0.042; cg_hitBeep 2"
    But cg_hitbeep sometimes stick to 0 or to 1 when i change the weapon too fast, so maybe the system avoid fast changes to avoid lags (due computation required).

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts