+ Reply to Thread
Results 1 to 6 of 6

Thread: libpng 1.4 not supported on linux!

  1. #1
    *mephist0666
    Guest

    Exclamation libpng 1.4 not supported on linux!

    Hi,

    I have 2 versions of libpng installed.

    media-libs/libpng
    Available versions:
    (1.2) 1.2.44
    (0) 1.4.3
    Installed versions: 1.2.44(1.2)(05:53:59 PM 07/16/2010) 1.4.3(08:29:21 PM 07/23/2010)
    Homepage: http://www.libpng.org/
    Description: Portable Network Graphics library

    When I normally launch firefox the version 1.4.3 is used.
    This is the result:
    http://www.abload.de/thumb/screenshot-3b4e7.png

    But if I use this command the version 1.2 is used and it looks normal:
    LD_PRELOAD="/usr/lib/libpng12.so.0" /usr/bin/firefox &

    Could you pls fix this so that command doesnt have to be used?
    Thanks!

  2. #2
    *XDrum
    Guest
    Amazing... where all the previous posts/3ds talking about this (still not fixed issue) are??

  3. #3
    *Mephisto_O
    Guest
    Quote Originally Posted by XDrum View Post
    Amazing... where all the previous posts/3ds talking about this (still not fixed issue) are??
    still not...
    but that's OK, beta's over, right?

  4. #4
    *XDrum
    Guest
    Meph, yes beta is over but the current QL addon is still linked to the "wrong" libpng:

    libpng warning: Application was compiled with png.h from libpng-1.2.24
    libpng warning: Application is running with png.c from libpng-1.4.2
    it's incredible ID is *not going* to fix this...shame

  5. #5
    *Solenero
    Guest
    I agree. It's a real shame.
    Preload libpng12 is a f u c k i n workaround...

  6. #6
    Member esdf is on a distinguished road
    Join Date
    Aug 2010
    Posts
    65
    Quote Originally Posted by mephist0666 View Post
    Hi,

    I have 2 versions of libpng installed.

    media-libs/libpng
    Available versions:
    (1.2) 1.2.44
    (0) 1.4.3
    Installed versions: 1.2.44(1.2)(05:53:59 PM 07/16/2010) 1.4.3(08:29:21 PM 07/23/2010)
    Homepage: http://www.libpng.org/
    Description: Portable Network Graphics library

    When I normally launch firefox the version 1.4.3 is used.
    This is the result:
    http://www.abload.de/thumb/screenshot-3b4e7.png

    But if I use this command the version 1.2 is used and it looks normal:
    LD_PRELOAD="/usr/lib/libpng12.so.0" /usr/bin/firefox &

    Could you pls fix this so that command doesnt have to be used?
    Thanks!
    This is the correct way to fix this, add something like this to your .bashrc, then source it.
    alias ffql="LD_PRELOAD=/usr/lib/libpng12.so /usr/bin/ffql"

    or just LD_PRELOAD=/usr/lib/libpng12.so

    you are preloading wrong one (.0)

    btw I suggest you don't send firefox to background, it's useful for backtracing the problems that await you once you fix this one (like game / browser crashes)

+ Reply to Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts